PowerShare Website/Web Application Issues

Incident Report for Diagnostic Cloud Solutions

Resolved

Issues resolved.

Note: RadBridge service may need to be restarted on impacted PowerScribe servers before reports will resume sending to PowerShare.
Posted Jul 07, 2025 - 18:01 UTC

Update

We are continuing to monitor for any further issues.
Posted Jul 07, 2025 - 17:07 UTC

Monitoring

Issue: We are investigating service issues on the PowerShare network.

Platform: PowerShare Network - (https://www1.nuancepowershare.com)

Behavior: Users may experience any of the following when using the platform
+ eUnity - Certificate not trusted, Error loading eUnity
+ HL7 Reports not updating
+
   -
Posted Jul 07, 2025 - 13:06 UTC
This incident affected: PowerShare Platform and Precision Imaging Network.