Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 20, 2026 - 07:00 UTC
Scheduled
Please be advised that routine maintenance is scheduled for PowerScribe One Cloud Speech.
This maintenance will be performed only on Cloud Speech systems in the US West region and will be completed in a rolling, non‑disruptive manner. Speech services are expected to remain available throughout the maintenance period, and no downtime is anticipated.
Users may continue to use the PowerScribe One application normally during this time. If you are unsure whether your organization connects to the US East or US West region, no action is required—this maintenance is expected to be non‑disruptive and speech services will remain available.
For real‑time updates or if circumstances change, please continue to check back to the Statuspage.
Posted Jan 15, 2026 - 22:22 UTC
This scheduled maintenance affected: PowerScribe One Cloud Speech (United States).