PowerShare Auto Order Generation Delays

Incident Report for Diagnostic Cloud Solutions

Resolved

AOG issues resolved.
Posted Aug 18, 2026 - 16:50 UTC

Monitoring

A fix has been deployed and we are validating.
Posted Aug 18, 2026 - 16:17 UTC

Investigating

Issue: We are investigating service issues on the PowerShare network.

Platform: PowerShare Network - (https://www1.nuancepowershare.com)

Behavior: Users may experience any of the following:
+ Delays for studies pushed into the Auto Order Generation (AOG) workflow
   - Study status not changing (stuck in blank or posted status)
   - Studies not routing through workflow.

Images: Users are encouraged to wait on re-pushing images to their AOG workflow as we are processing through a backlog.
Posted Aug 18, 2026 - 14:38 UTC
This incident affected: PowerShare Platform.