PowerShare Website/Web Application Password Reset/Set Issues

Incident Report for Diagnostic Cloud Solutions

Resolved

Password/Login issues resolved. Users are encouraged to repeat the password reset process for any failed user creations / password resets.
Posted May 21, 2026 - 18:35 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 21, 2026 - 17:11 UTC

Investigating

Issue: We are investigating service issues on the PowerShare network.

Platform: PowerShare Network - (https://www1.nuancepowershare.com)

Behavior: Users may experience any of the following intermittently:
+ Problems setting passwords for user accounts in PowerShare
   - Existing users may not be able to reset their passwords
   - New users may not be able to set their initial passwords
Posted May 21, 2026 - 16:55 UTC
This incident affected: PowerShare Platform.