Call volume is beginning to reach our Technical Support team successfully. We will continue to closely monitor service and provide additional updates as needed.
Posted Aug 13, 2026 - 17:51 UTC
Monitoring
We are currently experiencing an issue with our Technical Support phone system and may be unable to receive inbound calls. While we work to restore service, please use one of the alternative methods to open a support case:
We apologize for the inconvenience and are actively working to restore phone service as quickly as possible.
Behavior: Users may experience any of the following: + Problems calling support: (800) 833-7776 - Users may receive a notification when calling support "Your call cannot be completed as dialed."
Contacting support: Support cases may still be opened via email and via the support portal.
Posted Aug 12, 2026 - 18:53 UTC
This incident affected: PowerShare Platform and Precision Imaging Network.