Service Disruption: PowerScribe Smart Impression

Incident Report for Diagnostic Cloud Solutions

Resolved

As an update to our previous communications regarding the PowerScribe Smart Impression workflow disruption, service has been restored. Our engineering teams will continue to monitor.
Posted Jul 07, 2026 - 23:04 UTC

Update

Our investigation remains ongoing. Engineering teams continue to work toward restoring normal functionality for Smart Impression.
Posted Jul 07, 2026 - 21:46 UTC

Update

We are continuing to investigate reports of errors impacting Smart Impression workflows. Our team is actively working to restore normal functionality. Please continue to check the Statuspage for updates.
Posted Jul 07, 2026 - 20:17 UTC

Identified

We are currently investigating reports of intermittent errors affecting Smart Impression users. Our team is actively working to identify the cause and will provide updates as more information becomes available. Thank you for your patience.
Posted Jul 07, 2026 - 19:40 UTC
This incident affected: PowerScribe One Cloud Speech (United States).